No announcement yet.

Guardians of the Galaxy purchase issue

  • Time
  • Show
Clear All
new posts

  • Guardians of the Galaxy purchase issue

    downloaded the game last night, purchased guardians of the galaxy table, played it for a few hours last night, all was well.

    tried to play it today, and selecting the table in the game now says:

    "You already own Guardians of the Galaxy. You can find it in your games and apps collection"

    it has my high score from last night, so clearly I've played it, but now it puts me in an endless loops of saying I have it already but does not let me play.

    I've tried uninstalling the core game and this table, but this table never uninstalls, it won't go away and let me re-install, nor will it ever let me play!

    I bought the civil war table and it works fine, I can play uninstall/re-install just fine, what can I do to get rid of the Guardians table and/or be able to play it again? it ignores all attempts to remove it.

    I even tried "moving" it to an external storage device, then powering down that device, so I could re-install it locally. Same issues all over again. it "installs" from the store, but in game I can never play it.


  • #2
    Did you try this?

    "My Games & Apps >Select Pinball FX2> Push the Menu Button >Select ‘Manage Game’ >Scroll to the far right and you will see a list of items under ‘Ready to Install.’ You can select all, and these will install to Pinball FX2"

    That's from the FAQ, and has worked for two people I know who had the same issue.


    • #3
      yes, that's exactly what I do, however the table is always considered installed - and can't be uninstalled, within the game itself, and the "manage game" menu, and even the xbox store app, all consider it to be "installed" on the internal HD yet there's nothing I can do with it. It refuses to work, or let me purge it from my system forever. This is beyond frustrating and a waste of money.

      and this was only a new purchase, i never played this on the 360


      • #4
        it's shame that purchase problem so did you try to contact the help ??


        • #5
          i gave up on this game, nothing ever worked, nothing was ever fixed, can't even uninstall the damn thing from my drive, i wish I never played it or purchased anything, such a waste