No announcement yet.

Table Bugs

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nekro Neko
    Don't forget about Spiderman's bugs. Like the Doc Ock claw one and the captive ball bug when it switches place with a pumpkin bomb. I'd also add gamebreaking exploits into that list like JJJ's levels helping you with the orbits and such. Nice thread mind you.

    Leave a comment:

  • Cloda


    Game Breaking: During Romulus multi-ball the "Scale of Justice" mission start when it shouldn't. The game is not aware that you have two balls so the camera goes back to normal view. When you lose one of the balls, the game reacts as if you lose a normal ball and takes you back to the plunger, ignoring the other ball. The new ball that launches and then you are back to the 2 ball multi ball... but same as before, if I lose 1 ball, the game ignores the 2nd one.

    Game Breaking: At some point during a game when you choose between "justice" or "mockware", choosing "justice" you can find that nothing happens, the ball disappear, and you can't do anything except restart the game.

    Bug: During Wizard Mode in Rome there can be a problem with the "Scales of justice". The left scale is lowered while it shouldn't be. The ball falls all the time and when it happens, a new ball is launched so the game can keep going.

    Bug: Upon activating the trebuchet, the ball can "fall out" of the rails leading to the weapon. This can leave the camera stuck off to the left side.

    Bug: During Western Garrison multiball : if you shoot two balls at the same time (or one very quickly after another) into the charged portal, the game will still give back only one ball (instead of two), thus immediately stopping the mission and coming back to regular game.

    Misfeature/Bug??: During a multi-ball, with the right kickback activated 2 balls can go into the right kickback at the same time. The kicker doesn't have enough power to get both balls back in play and this continues (scoring points) until you nudge the table.

    Sorcerer's Lair

    Bug: Immediately following the "Behind the Wall" mission table bump doesn't work which can lead to a drain if you want to do a flipper pass e.g. to immediately start the Midnight Madness mode.

    Misfeature: The Sharp Shooter Achievement is not only being awarded for achieving the required all spiders in 20 seconds during the Arachnid Mission. Most people have been awarded it at random times during the game... some not even having completed the Arachnid Mission once.

    Misfeature: The table doesn't have an audible tilt warning only visual.

    Misfeature: Often times when you light the Extra Ball light for the second time with the same ball there is no audible indication. Scoring that Extra Ball then is also often not announced.

    Misfeature: Sometimes the Jackpot does not register when you hit Whisper. Even with a completed shot.


    Game Breaking: During Doc Ock mission, Doc will mistakenly grab the capture ball instead of a live ball. When this happens, Doc will never release the ball (The few times it happened to me the ball was in one of the left claws). You can continue the game, but eventually when you drain the ball the game will become stuck and won't start a new ball. Only choice is to restart the game.

    Game Breaking: Both Goblin and Ock battles were active, Ock grabbed my silver and pumpkin balls at the same time I hit the apartment with the 2nd pumpkin ball. Doc Ock grabbed 2 of my balls and held the silver ball indefinitely, but released the pumpkin bomb. So Ock held 1 silver, had another silver in play from the captive ball which the pumpkin bomb replaced, and 1 live pumpkin ball. I timed out on Goblin and my live pumpkin ball vanished leaving 1 silver ball in play and 1 held by Ock with the pumpkin bomb still acting as the captive ball up top. I then hit the apartment and it released the pumpkin ball and I was playing with that for a while.

    Finally drained and the game just froze like I still had a ball in play. I think the game counted the ball Doc Ock was holding as "in play". I waited about 3 mins to see if it would reset itself and pop a new ball in play... It didn't and I was forced to restart my game.

    Game Breaking: During a game, while on ball 2, Doc Oc grabbed a ball from the play field, and placed it on the right ramp. As the ball descended down towards the flippers, the dot matrix said "Game Over", the flippers went dead, and the ball fell down between the flippers. Note: I did not TILT.

    Game Breaking: During a game, I was in a mode that had Doc Oc and Mysterio going simultaneously. Doc Oc grabbed a ball from the play field, and held it in his claw. Time ran out on the Mysterio mission, and the game was essentially stuck. I tried Tilting, exiting the game and resuming... nothing worked.

    Game Breaking: Ball 1, GG level 2 with two pumpkin balls on the table and sent one of them straight up the right ramp (which was lit) I then lost the ball SDTM and at the same time sent the other pumpkin ball up the right ramp as well. The game just stuck, no end of ball bonus, unable to tilt the table I had to just end the game as nothing happened from just waiting

    Game Breaking: Was playing level 2 GG and for some reason the others started in. Then, somehow, the captive ball got loose and I was multiballing with it for a long time. With the captive ball loose, I had serious troubles completing different parts. Getting the left webramp was near impossible. Going to the apartment would not drop the ball up top, but rather drop it on the right side by the flipper.

    Bug: Defeated Doc Ock, yet his mode immediately restarted. Doc Ock didn't move back to his original position.

    Misfeature: Was playing either the 3rd or 4th round of Doc Ock, hitting the centre ramp repeatedly for 500K each time. After a while of doing this, the Doc Ock theme music became really intense; double-time. When I finished the stage, the music persisted, and hung around for another five minutes or so, before suddenly stopping half-way during a Mysterio stage.

    Misfeature: When you hit the far right hole that gives you a random upgrade (big score, all villians let loose, etc) a problem can occur if you hit it with two pumkin balls in a row. The game can keep on playing the hole's jingle non-stop until it is game over and you reset the game.

    Misfeature: Reward Hole music and DMD sequence sometimes continues for an extended period. Seems to happen more often on very long games, particularly during the JJ Hurry Up.

    Misfeature: If Doc Ock is activated while you activate Mysertio's mode, a Mysterio model can becomes stuck inside Doc Ock when he goes back to his prone position.

    Street Fighter II

    Misfeature: Sometimes the "ball saved" light doesn't light up during the beginning of a multiball. It still works, but you have no way of knowing it turned on, or when it turned off because the light never started blinking.


    Bug: During "Fast Ball Special", if your ball drain while ball save is activated, the relaunched ball goes around the top and then straight down the middle with zero chance to save it as the ball has no drag on it to slow it down.

    Bug: Sometimes, Claw Save doesn't let the ball settle long enough before launching it back on to the playfield, with the result that the ball hits the underside of the flippers, resulting in a drain

    Bug: Teeter-totter/diverter on centre ramp (activate Silver Samurai lock ramp) was "stuck in the middle" and would not allow any shots to be successfully completed. Diverter eventually was bumped back into a proper position after several (5-10) failed ramp shots. Diverter operated normally for the remainder of the game.

    Misfeature: In common with other Zen tables, a kickback will be detected if a ball gets past the bottom flippers and rolls up the side of the tables in to the Kickback area. The ball will be magically teleported to the kickback location, and kicked out. (This is good for the player, but exposes the man behind the curtain.)

    Misfeature: Wolverine says "Clever!" even if you miss the death save.

    Misfeature: You can get 5 extra balls per real ball, compared to 3 on the PS3 version.

    Misfeature: The left kickback sometimes kicks the ball directly in to the right outlane!

    Misfeature: Occasionally, the ball will be ejected from the SNIKT saucer immediately, instead of after a short delay.

    Misfeature: After the third (or fourth?) wizard mode, the "Danger" and "DANGER" warnings no longer appear on the DMD, and the danger sound fx do not play.


    Bug: On several tables during Hotseat play, the tables fail to reset between players. e.g. on SotD with a 2 player hotseat game player 2 can start with the sub advanced and lights lit from player 1's game.

    Bug: Not a table bug but a forum bug. You can't upload jpeg images as they are not recognised by the system.

    Misfeature?: Physics is possibly different on orginal elite 360(1080i via HDMI) vs slim 360 (1080P via HDMI) see thread. e.g. On captain america table, on the new Xbox, the ball won't capture on the right flipper when starting a mission.
    Last edited by Cloda; 12-13-2011, 06:16 AM.

    Leave a comment:

  • Cloda

    Fantastic 4

    Major Scoring glitch: At the end of the Human Torch mission, if you drain the Nova Flame Ball as soon as its activated, you get a 40x multiplier for your end of ball bonus.

    Game Breaking: During Dr. Doom mission, if you shoot an unpowered ball up the Dr. Doom ramp and you have Negative Zone ballsave activated the table can freeze. Alternatively once the Negative Zone ballsave has been used and the table doesn't freeze, it can't be reactivated for the rest of the game.

    Game Breaking: With both shields activated as well as the NZ ballsaver the ball falls down the middle and the portal opens but rather than the ball getting pulled into the portal it goes behind one of the shields where it gets stuck. The ball disappears/sink into the table behind the shield, the portal is still open, the table is flashing very brightly and all the characters is doing their normal thing. The ball doesn't get reset and you can't tilt the table so your only option is to restart the game. It was reported happening during the Doombots mission and getting stuck behind the right shield but it is assumed that it can happen during other situations as well.

    Bug: If you play the Human Torch mission last and drain you Nova Flame ball, the table resets and you have to restart all the missions again.

    Bug: Whenever you hit the F-O-U-R skill shot, if you fail to hit another letter (popping up from bumpers below) before everything stops flashing, the letter stays lit and won't move with flipper presses. This usually lasts until the ball drains, making it more difficult to increase the bonus multiplier.

    Bug: When failing the normal skill shot at first, but switching it while the ball gets bumped up, gets the multiplier light stuck.

    Bug: After completing wizard mode, and you have the Gift of Thing active it sometimes wouldn't register hits to his blocker shield (all three) when you make contact with them. It makes the "rock" noise, but the shields won't drop.

    Misfeature: If you play the Human Torch mission and complete it, the final mission hole is activated resulting in many of the targets/holes not being active during the Nova flame ball 40x score mode.

    Misfeature(?): The amount of points being awarded for completing the Dr. Doom mission seems to be very few e.g. 2 million.

    Misfeature: All the scores on the leaderboard ends with 000 - this makes it feel artificial and pointless. Suggested fix is to slightly change the points you get from the bumpers.


    Misfeature/Bug??: Having a kickback active and nudging the table right before it hit the repulsor beam can result in missing the kickback.


    Bug: Can't see what letters are being entered while entering initials for the local leaderboard. Display is in the middle of the screen, but is not the typical Select-your-Letter screen but a screen showing your high score.

    Bug: On activating "Sunstorm" the ball can become trapped for several seconds underneath the ship resulting in an automatic mode failure. The ball can at times also change rails from left to right/visa versa underneath the ship.

    Ms. Splosion Man

    Bug: During the splosion multi ball. After releasing the last captive ball or having a ball still captive and and draining the other balls at about the same time. There still remains 1 live ball left but the game counts it as a drain. Once the EOB bonus was awarded, a new ball was released to the plunger, the whole while I was still able to play and score with my live ball. After plunging the new ball I had a 2-ball multiball going with the table not registering as in any multi ball mode. The game did not count another drain until I had lost both balls.

    Bug: The achievement for 100 Splodes is currently broken. It appears that you have to score many more splodes before you are awarded with the achievement.

    Nightmare Mansion

    Game Breaking: Sorry Zen, can't describe the exact circumstances, but I drained the ball after the (harsh) Witch Bonus noise played. Then the noise started repeating. There wasn't any obvious rhyme or reason to it: it would speed up, playing several times a second, then slow down to once every few seconds, then start up again. The Witch Bonus was advanced 50K each time. After it built to 1 million, I received an Extra Ball. And another Extra at 2.5 million. The noise petered out after the Witch Bonus had built to over 4 million.

    Misfeature/Bug??: Unlike more modern tables, the "Shoot Again" light is not permanently lit when receiving an Extra Ball. Instead, we get "Ball 4", "Ball 5" etc on the DMD.

    Misfeature/Bug??: There is no Status information displayed on the DMD when a flipper is held.

    Misfeature/Bug??: If the Shoot Again light stops flashing while the ball is in a drain lane or trough, the ball is lost. There should be a grace period, as on more modern tables.

    Misfeature/Bug??: No ability to change the (ugly) DMD color.

    Misfeature/Bug??: Harsh, over-loud sound samples. Particularly the cat shriek and the bats squeals.


    Game Breaking: Ball disappear during guards mini-game. Player gets kicked back to main table with a new ball but the mini-game is still active. No other modes on the table can be activated and when you lose the ball no new ball appears - even if you Tilt the table. To reset the table you then need to quit the game so that the save is erased.


    Game Breaking: During levitation multi-ball, a ball can get stuck on some of the tables structures. The ball doesn't reset even if you Tilt because the ball still slowly rolls making the game think that the ball is still in play. Some people have been able to dislodge the ball after many minutes of bumping the table.

    Game Breaking: As the ball comes out of the haunted house and you hit it with the top flipper it can get stuck in a similar way to the previous game breaking bug.

    Game Breaking: During levitation multi-ball it can happen when you use the magna save on the levitating ball that the game goes out of the mode but without the levitating ball dropping. When you lose your ball, the levitating ball still slowly moves from the screen as it normally does, but no new ball is launched. Under certain conditions a ball can get launched though after this happened for the game to continue.

    Game Breaking: Either during or immediately after Levitation multiball jackpot there can be a very strange graphical effect. The surrounding area of the board grew dark, and it seemed almost as though the upper surface parts of the board faded out. It only lasted a few seconds. Afterwards things went back to normal. When I drained I ended up going into video mode and returned to the board with no ball reset. From there on I can nudge the board infinitely without consequence, the flippers all work, but I never get my third ball. It continues through a saved game as well, I can quit and come back and my board's in the same state.

    Bug: At some point during a long game it can happen that the non lit holes on the cube stops working. When the balls goes in there, you don't get a clairvoyance reward (e.g. light extra ball) and the ball don't appear again. It gets relaunched a couple of seconds later.

    Misfeature/Bug??: Many times when the ball gets to the cube it just runs past without first slowing down.

    Misfeature/Bug??: All of a sudden, without any apparent reason, Tilt warnings disappeared. No voice or dmd indication. Some time later things can start to work properly again e.g. "Video mode"

    Rocky & Bullwinkle

    Scoring Glitch: One of the locked ball become stuck when locking them and never pops back into play, thus a three ball multiball is instead a two ball mutli-ball and, if you drain one, the jackpot lights remain lit and can be scored with a single ball until the original stuck ball becomes unstuck (Usually only requires a nudge of the table).

    Misfeature/Bug??: No indication that ballsave is about to turn off. Ballsave should/could flash faster for a few seconds before turning off.
    Last edited by Cloda; 12-13-2011, 06:10 AM.

    Leave a comment:

  • Cloda
    started a topic Table Bugs

    Table Bugs

    Although Zen's tables are brilliant and of high quality the occasional bug does slip through. To avoid the same bug being repeatedly reported (thanks Kimkom for pointing out the error in my ways ) I will note them in this thread as they are reported.


    Game Breaking: During the Sniper Mission, the game kicks out the locked balls before the mission is completed. The next shot to the tanker will NOT lock in, but the Mission is STILL active with the DMD flashing "Lock Three Balls Into the Tanker!". It is then impossible to finish this mission....and impossible to start another one with this active, totally hampering any scoring.

    Game Breaking: During the Sniper Mission after three balls are locked the video mode doesn't start, instead only the multi-ball starts. The mission is then stuck.


    Bug: The frenzy hole can get glitched up by the metal thing in front of it blocking it.

    Game Breaking: It is possible for the ball to bounce up/above the playfield on this table. During multi-ball I had the ball bounce up and land directly behind the wheel target/multi-ball lock hole. The ball is stuck and there is no way to nudge it out. If you drain any remaining balls, the game will not start a new ball. The only option is to restart the game.

    Misfeature/Bug?: 10x mutliplier is not attainable from bumpers. 2x,4x,6x,8x, extra ball are all attained from hitting the "mushroom" bumpers on the left side of the table. The table never rewards 10x from the bumpers, regardless of the number of times you hit them. 10x is shown on the table playfield, so we can assume there is a way to activate/light 10x.

    Captain America

    Bug: The view incorrectly zoom out during the Zemo's Castle mini-game if the ball hits the bottom of the mini-game.


    Bug: Captain Zemo Castle mini-game sometimes doesn't work after Assault has been spelled. The timed mission starts, the lights are lit, but the game doesn't activate when the ball enters the castle. For some people it happens each time they spell Assault and not just sporadically.

    Bug: Bucky Howler isn't awarded if you shoot the right ramp quickly after the skillshot.

    Bug: The right ramp sinkhole is sometimes active when you achieve a skillshot so you can't achieve Bucky Howler.

    Bug: During Resistance mode team members can go missing if you use the Cosmic Cube.


    Bug: Ball flailing of the Assault Ramp rails and deflecting somewhere else on the table. This can happen at any time; during missions and even at ball launch.

    Bug: During multiplayer split screen if you tilt the table excessively, you will after a while see a random score pop out of nowhere. After the score pop up, you will be able to launch 2 balls into the game. Due to unlimited balls in multiplier split screen you can do it each time. Has not been tested yet on xbox live.

    Bug: During the Death Ray Mission the DMD display sometimes gives the wrong information in that while you are required to deflect the rays after you have acquired the required strength, the DMD is still on the "Strength Meter". It doesn't though prevent you from completing the mission.

    Bug: Losing you last ball during some of the stages of the Wizard mode results in an additional ball being made available to launch. This ball stays in play until you hit the cosmic cube and the actual multiball stage starts.

    Bug: I appears that after a long game (2 x wizard mode completed) the Zemo/Redskull target doesn't register a hit on it and the right ramp sinkhole to start a mission doesn't open.

    Bug: During Dig Site Mission, if ball drains immediately after hitting the dynamite target, (to win the mission,) points are awarded like usual, but the light on the playfield does not light. You are then not able to select that mission again, when selecting another Cap's Hole mission. This presumably prevents you from reaching Wizard mode (not tested).

    Misfeature: During the Red Skull Mission you get more points for the holes where you get hit by the Red Skull than for hitting the targets where you hit Red Skull.

    Misfeature: There is no sound effect when Bucky saves you.

    Misfeature: The supply-drop mini game has no sound effect to indicate that it is active.

    Misfeature: Following the completion of the Wizard mode or the Sleeper Multi-ball the sound effects accompanying the Sleeper Robot continues in the background for the rest of the game.

    Misfeature: Sometimes after failing a mission, when you restart it again the accompanying sound bit is not played e.g. Adhesive-X mission.

    Earth Defense

    Bug: When you start Panic Multi-ball and immediately lose the first ball the DMD display gets stuck on a screaming lady holding her head. From there on the DMD does not display your score and more importantly the Invasion count down timer. Other DMD instructions still appear e.g. Invasion prevented, second Wave coming.


    Bug: The Hidden path blockers get stuck.

    Bug: The Right Orbit often doesn't count.

    Game Breaking: Remaining Ball becomes stuck behind hidden path targets after failing the Sir Percival Mission. There is no way to nudge the ball back into play. The only option is to restart the game. This is a very rare/unique set of circumstances that I've never seen anyone else comment about. I don't recall if the stuck ball came from an orbit shot to the right or a failed orbit shot/hidden hole shot on the left.


    Bug: Ball gets stuck.


    Bug: When losing the last 2 balls of playground multi-ball simultaneously, bungy save won't take effect until after a new ball is launched. I thus doesn't perform its function of saving the ball.

    Scoring Glitch: The hole at the top right of the board will intermittently not kick the ball out with enough force for it to re-enter play, causing it to fall back into the hole, and score more points. Once it gets stuck like this you can just leave your console on forever, and continue to get points. It takes a nudge of the table to get your ball out.

    Low quality video of the glitch

    Misfeature: Right after I activated Playground multi ball, somehow two balls got stuck underneath the third flipper. I got them unstuck by shooting the ball left in play into the playground and letting it drain into the bottom playfield, unclogging the jam.
    Last edited by Cloda; 09-28-2011, 07:02 PM.