Announcement

Collapse
No announcement yet.

Pinball FX 2 - bugs/issues and recommendations

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • binaryfox
    replied
    A recommendation I would have is to allow players to select their Tilt/Flipper buttons themselves. On my keyboard the Ctrl keys are very close to the flipper keys and accidentally tilting the table is easy. I tried the other layouts but they are too far away to the flippers to be useful. I would like to use Left Shift and \ and / and Right Shift, but this is not aloowed at present.

    Greetings

    Leave a comment:


  • LeanderL
    replied
    Originally posted by shogun00 View Post
    The scroll cameras don't work properly when multiple balls are present. That's why the game has to force the angle to a fixed/locked one during multiball modes. You have three cameras to choose during the multiball ball, so try switching the angle and go with the one that works for you.
    Thanks. Ah, that makes sense, yes. I usually play with the first view (1, not 0) which is a static view so I didn't think of scrolling cameras and multiple balls.

    Leave a comment:


  • Roo5676
    replied
    The arena bug on hulk that I've seen reported previously is still there on this version. On one of the 8 or so times that I got to the arena today, no ball was launched. I shook the table and the ball then was spit back to the playfield, but the flippers then didn't work, despite making their sounds. I heard no tilt warnings so I don't think it tilted. The next ball launched didn't fix it so i had to restart.

    Edit: the flipper sounds I heard were probably the flippers in the arena still going while the main ones were deactivated.

    Edit2: This has been fixed. Thank you!
    Last edited by Roo5676; 05-27-2013, 03:26 AM.

    Leave a comment:


  • shogun00
    replied
    Originally posted by LeanderL View Post
    And in addition to my previous ideas please think about fixed cams (user selections) that do not automatically change during multiball. I know that the view must be changed for certain minigames etc. but the zooming out during multiball really doesn't make sense.
    The scroll cameras don't work properly when multiple balls are present. That's why the game has to force the angle to a fixed/locked one during multiball modes. You have three cameras to choose during the multiball ball, so try switching the angle and go with the one that works for you.
    Last edited by shogun00; 05-12-2013, 08:35 PM.

    Leave a comment:


  • Fpala
    replied
    Update the 5.1 sounds - Possibilty to move the dmd with mouse- Hide pause/cam button

    Update the 5.1 sounds please:

    During the game, all sounds are in the center speakers, except the sounds of Special Effects ?? That is very unfortunate...
    For me, your greats music’s themes during the game should be in the 4 others speakers...

    -Give us the possibilty to move the DMD with the mouse control, make this dream comes true !

    And please, hide the pause/camera on the top who disturb the visibility of the game...

    Thanks
    Last edited by Fpala; 05-12-2013, 09:00 PM.

    Leave a comment:


  • LeanderL
    replied
    Barbie, please take a look at this screenshot. The arrow next to "Tesla" looks damaged. It looks strange imo...if you hover this "something" the back arrow is displayed but without hovering it it looks odd. It's like that in all tables (not just in "Tesla").

    http://abload.de/img/2013-05-12_00001u6upj.jpg

    Leave a comment:


  • LeanderL
    replied
    Adding the Mars table would be cool.
    And in addition to my previous ideas please think about fixed cams (user selections) that do not automatically change during multiball. I know that the view must be changed for certain minigames etc. but the zooming out during multiball really doesn't make sense.

    Leave a comment:


  • kingcozy
    replied
    Originally posted by iCub View Post
    See here for others with the same problem and the solution they discovered:-

    http://steamcommunity.com/app/226980...8532661899236/

    I hope this works for you.
    Bingo. Thanks a lot! Now I can enjoy this game.

    I did a bunch of searching too before posting a thread, sorry! I hope others can find the solution as easily as I did. It's a shame it's such a non-obvious bug though.


    For those who don't want to click links - make sure you have Vertical Sync set to "Let 3D Application Decide" in your Nvidia control panel - then make a new profile for Pinball FX2, and set Vertical Sync to ON.

    My problem was that I had Vertical Sync turned off by default in my Nvidia Control Panel for ALL games and software. I guess Pinball FX2 REQUIRES VSync to be on or it doesn't run properly, hence the sped up effect.

    Hope this helps, and thanks again for your link!

    Leave a comment:


  • iCub
    replied
    This comes under recommendations:-

    Add the Mars table that comes free with the Windows 8 version

    The Steam community is living up to their name and getting rather "steamed" up that Windows 8 users get a freebie table but the Steam version doesn't.


    Bring back the "low quality" mode from the Windows 8 release to allow use on Atom based tablets and older PCs/Laptops. (I know Solitude kindly replied to me in another thread that he will look into this, but I thought it worth including in the recommendations thread too incase other players are interested).
    Last edited by iCub; 05-12-2013, 04:16 AM.

    Leave a comment:


  • iCub
    replied
    See here for others with the same problem and the solution they discovered:-

    http://steamcommunity.com/app/226980...8532661899236/

    I hope this works for you.

    Leave a comment:


  • kingcozy
    replied
    Game runs at 500x speed!

    Okay, I don't know if it's ACTUALLY 500x speed, but as soon as I get to the main menu I can see that the game just starts speeding up like crazy. The flaming Pinball FX logo's fire animation starts speeding up like CRAZY, and when I actually load up a table it's INSANELY fast - way too fast to play. Everything from the character animations on the table to the actual ball physics are sped up.

    I've tried updating my drivers, running in windows compatibility mode, changing the executable's CPU affinity to a single processor, changing the resolution, trying to go into windowed mode (you can't), launching the executable directly from its installed Steamapps location, etc. etc.

    I'm stumped.


    Anyone else have this problem? I just bought this game and would love to play it, but it's completely unplayable like this.

    Leave a comment:


  • shogun00
    replied
    Originally posted by rooter View Post
    Does anyone else have major flipper lag?
    Yep! I'm trying to figure out what's causing it on my build. I came up with four possible solutions, but I don't have time now to check them out at the moment.

    1.) Make sure the graphics card driver is up to date.
    2.) Make sure your monitor is set to "game mode".
    3.) Check the graphics settings on Windows and make sure that there aren't any motion enhancing* filters running.
    4.) Try lowering the resolution and/or turn off the ball trails and anti-analyzing. Those use up quite bit of GPU memory.

    * Motion enhancing only works on content with 30fps or less. It doesn't work too well with 60fps games. Usually both the monitor and graphics card have these features available.
    Last edited by shogun00; 05-12-2013, 10:48 PM.

    Leave a comment:


  • rooter
    replied
    Does anyone else have major flipper lag?

    Leave a comment:


  • Praag
    replied
    Originally posted by LeanderL View Post
    My thoughts:

    1) pause and cam buttons: hovering them displays them but if the mouse is not on them the buttons disappear. You can change the cam with c so the big button is useless. I know it makes sense on tablets etc. but Windows users should at least be able to get rid of them. Something like "display buttons yes/no" in the settings.

    2) Adjustable DMD. Not that difficult to implement...you can freely move the DMD anywhere on your screen (options menu)

    3) Highscores: "remember me" function. If you play single player entering the same three letters all the time is not convenient.
    Totally agree. I also suffer a bug entering the Arena, the ball simply vanished, right flip stay up, nothing i can do except quit the game.

    Leave a comment:


  • Roo5676
    replied
    View 1 or 2 seem to be the best for a cabinet. The angle on 1 seems slightly better, but I wish I could pull it back just slightly.

    I do wish you could disable all special cameras though. Right now it goes back into them every time (launching ball normally, launching ball from left "Hand" plunger on Wolverine, Darth Vader talking to Boba Fett, etc.) You can hit the camera button during it and go back to your full table view, but it doesn't stick.

    Agree on removing the massive pause button.

    Agree that there is no good place for a medium-sized DMD. Lower left seemed ok, but on some tables (Biolab) it actually overlaps the flippers a little. Being able to move this to another monitor (or real DMD! ) would be nice.

    And someone mentioned it somewhere - a brightness option would be nice. Seems to be a bit too bright - it's a bit harder than it should be to see the ball against the yellow Wolverine playfield, for example.

    I posted another thread about getting Xpadder working for my controls. It would be nice to have support for any controller (besides Xbox 360 controller).

    Honestly, most of my complaints are cabinet-centric (for which I know support is going to come later). The game is fantastic and totally playable with my Xpadder setup. Maybe at some point I'll start a cabinet-mode wishlist thread or something.
    Last edited by Roo5676; 05-11-2013, 01:49 AM.

    Leave a comment:

Working...
X