Announcement

Collapse
No announcement yet.

Flipper lag problems when playing with Intel 4400 graphics

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Flipper lag problems when playing with Intel 4400 graphics

    I just got a Surface 2 Pro, which is an Intel i5 CPU with built in Intel 4400 graphics. Pinball FX 2 runs fine on this rig, the frame rate is very smooth... but there is an input lag problem. When you press any control, the screen responds a fraction of a second later.

    This was on a bone stock Surface 2 Pro. Installing Steam and Pinball FX 2 was the first thing I did. (The game automagically selected a lower resolution mode and turned off some effects, by the way.)

    I did a lot of Google searching and the consensus seems to be that adjusting the Maximum Pre-Rendered Frames setting in your graphics driver is the way to combat this problem. Unfortunately, the Intel graphics chip does not expose this setting to the user. In fact, the Intel driver provided by Microsoft doesn't even come with a visible control panel. If you update the driver manually to make the Intel graphics control panel available, it does not offer the Maximum Pre-Rendered Frames setting anyway.

    Has anyone figured out a solution to this, maybe a registry tweak?

    Is there a way to appeal to the developers to address this issue in the game itself? I can't be the only person playing on Intel graphics.

  • #2
    Interesting, I'm noticing similar problems with my pinball cab I built, which uses the same haswell chipset for video. Or at least I'll say, some of my friends are. Maybe I'm used to the lag...

    However, it only seems to happen with keyboard control, and only on some tables, most noticeable in the newer ones like Star Wars. Using a plugged in Xbox controller seems to reduce the lag. Which makes me wonder if it is really a video issue, or a keyboard lag bug?

    PS - I have a Surface Pro 1, and never noticed any lag, and that's a chipset behind. However I only ever played with an xbox controller, so I'll see how it behaves with a keyboard.
    Last edited by Raidy; 03-05-2014, 12:08 AM.

    Comment


    • #3
      The lag I am seeing is not subtle. If you had the same problem, you wouldn't be second-guessing yourself. I'm estimating it at at least 100 ms.

      It's a good idea to figure out if the problem with with the graphics or the input. I had assumed graphics because of so many similar posts from AMD and nVidia users... but that ain't proof. I'll try to find a wired Xbox controller, try an external USB keyboard, and anything else I can think of...

      Thanks!

      Comment


      • #4
        Strange, I run this on i3/HD4000 laptop and don't notice any issues?

        Comment


        • #5
          Yeah, beats me, but your experience makes me optimistic that there is a solution out there somewhere. That's good to hear.

          Comment


          • #6
            I have noticed it a bit too. I am using a Lenovo yoga 2 pro, i7 version with 4400 graphics. The worst offender seems to be the new soccer table, which also seems to run at the lowest framerate.

            Since I dont know if there is any way to adjust the pre rendered frames or any advanced graphics options I think the best way to combat the input lag is just to make sure your game is running at the highest framerate possible, whether that's lowering the resolution or turning down graphics options.

            Of course if anyone finds a better solution, let me know!

            Sent from my GT-N7105 using Tapatalk

            Comment


            • #7
              Here's a little more information.

              I tried playing with an external USB keyboard. As far as I could tell, the amount of lag was unchanged--it was really bad, making the game unplayable.

              I then tried with a wireless Xbox controller. Lag was much improved. I would say it was reduced to about one third of what I saw with the keyboard. The game still suffers pretty badly though; you still have to think really far ahead to have the chance to make a shot. It's no fun this way.

              The tests were conducted with the very newest official Intel graphics drivers as provided by Microsoft, version 10.18.10.3431. That update was just released today, 3/11/2014. Microsoft now exposes the Intel graphics control panel, but there are no options exposed that seem to help.

              Aside from Steam, a few games, and Chrome, my Surface 2 Pro is completely stock.

              Any other ideas?

              Comment


              • #8
                You should try disabling other processes that you are not using with windows taskbar, maybe even turning high contrast settings on. These worked for me on my older pc when I was trying to run Visual and Future Pinball. If you are running an AMD based graphics based system there is a great program called Radeon Pro and this will definitely clear any lag problems what so ever.
                Bonus multiplier goes nuts on drains

                Comment


                • #9
                  I think the problem is related to the input path or some peculiarity of the GPU path--perhaps that "max pre-rendered frames" setting that I can't adjust. The frame rate is already silky-smooth. I haven't installed anything to actually measure it but it has got to be around 45 fps, maybe higher.

                  I'll try reducing graphics quality as much as possible to be sure, but I am not optimistic it's the path to success.

                  Comment


                  • #10
                    This is a bit late but, if you still are having lag problems you can adjust flipper strength from the operators menu and it will not effect your online scores ( had to do this with all my tables on PS3 our TV does not have a game mode setting ) simply sellect Utilities then U.4. Extra Adjustments from there you can adjust your flipper strength by using a lower setting then the factory one. Hope this helps.
                    Bonus multiplier goes nuts on drains

                    Comment


                    • #11
                      Thanks, I will try that.

                      Comment


                      • #12
                        You could also try this might make a huge difference it does on Radeon http://steamcommunity.com/app/226980...7315349070543/
                        Bonus multiplier goes nuts on drains

                        Comment

                        Working...
                        X