Announcement

Collapse
No announcement yet.

Choppy framerate, unplayable on Windows 10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hajdu
    replied
    Originally posted by sabrehawk View Post
    i just reinstalled this app on windows 10 after a long time of absence . It runs at a framerate that is totally unacceptable / unplayable.

    The system is a GTX 980 M with a Skylake 6700 I7 and 16 gb ram running of a Samsung 960 NVME .

    How is that even possible that there next to none GPU usage in taskmanager while the game is barely functioning when playing a table. Framerates below 20 i would say. Totally unplayable. This game runs on tablets how is that even possible?

    Im using the latest nvidia drivers. Note that this is NOT a OPTIMUS system, and the onboard IGPU is hardcoded disabled by the manufacturers stock bios and cant be turned on or off by the user.

    Im also running on balanced power connected to wall jack , not in battery mode.

    It runs about as well as your forum hosting btw. Horrible.

    Due to the retarded way Modern UI Apps work i cant reference a accurate screenshot of my task manager, but the load of the gpu is only at 25% max with a abysmal framerate at 4K resolution.
    Hey,
    have you tried setting your Nvidia video card to the default GPU for FX3?
    https://www.techadvisor.co.uk/how-to...-card-3612668/

    Kind regards!

    Leave a comment:


  • sabrehawk
    replied
    i just reinstalled this app on windows 10 after a long time of absence . It runs at a framerate that is totally unacceptable / unplayable.

    The system is a GTX 980 M with a Skylake 6700 I7 and 16 gb ram running of a Samsung 960 NVME .

    How is that even possible that there next to none GPU usage in taskmanager while the game is barely functioning when playing a table. Framerates below 20 i would say. Totally unplayable. This game runs on tablets how is that even possible?

    Im using the latest nvidia drivers. Note that this is NOT a OPTIMUS system, and the onboard IGPU is hardcoded disabled by the manufacturers stock bios and cant be turned on or off by the user.

    Im also running on balanced power connected to wall jack , not in battery mode.

    It runs about as well as your forum hosting btw. Horrible.

    Due to the retarded way Modern UI Apps work i cant reference a accurate screenshot of my task manager, but the load of the gpu is only at 25% max with a abysmal framerate at 4K resolution.
    Attached Files
    Last edited by sabrehawk; 01-17-2018, 02:20 AM.

    Leave a comment:


  • hajdu
    replied
    Hey Guys,
    so sorry about this!
    But anyways swprozee1 is absolutely right and this would be my advice too.

    Thank you swprozee1 for helping out a fellow player!

    Wishing you all a happy holiday season!

    Leave a comment:


  • swprozee1
    replied
    possible solution

    Originally posted by 2hard4me View Post
    Bump...anyone?
    I would like to respond as nobody seems to help you out further.

    1 thing comes to mind reading about your problem.

    I know the Intel CPU you have has a Integrated GPU (4600) and it might be that Zen Pinball is running on the far slower Integrated GPU rather than your faster R9 280X 3GB GPU.

    Please do the following:
    Go into your BIOS of your computer and disable onboard graphics completely !!!
    That way we force any game to start running on your R9 280X 3GB GPU.

    Please let me know if that solved your problem. :-)

    Leave a comment:


  • 2hard4me
    replied
    Bump...anyone?

    Leave a comment:


  • 2hard4me
    replied
    Still waiting for a response.
    Thanks

    Leave a comment:


  • 2hard4me
    replied
    Still can't seem to solve the problem.
    Any suggestions?

    Leave a comment:


  • 2hard4me
    replied
    Originally posted by McLovin View Post
    Hello there,

    could I ask for your PC specs? If you play around with the video options is there any difference?

    Is the menu slow as well, or just the tables themselves?
    The moment I open the game it begins to lag, so it's not just the tables.
    I have tried messing with all of the video settings and putting them on the lowest options.

    PC Specs:
    Windows 10 64-bit
    16GB RAM
    Intel i5 4670K CPU @ 3.40GHz
    R9 280X 3GB GPU

    Also tried on laptop with these lower specs:
    Windows 10 64-bit
    16GB RAM
    Intel i7 CPU @ 2.60GHz
    GeForce GT 650M 1GB
    Last edited by 2hard4me; 10-19-2017, 05:09 PM.

    Leave a comment:


  • McLovin
    replied
    Hello there,

    could I ask for your PC specs? If you play around with the video options is there any difference?

    Is the menu slow as well, or just the tables themselves?

    Leave a comment:


  • 2hard4me
    started a topic Choppy framerate, unplayable on Windows 10

    Choppy framerate, unplayable on Windows 10

    Whenever I open Pinball FX2 for Windows 8 or Pinball FX2 for Windows 10 it lags my entire PC and I get about 5-10 frames per second in the game, making it unplayable.
    As soon as I exit my PC goes back to normal.

    It's weird because I used to be able to play these games without any issue, it only seems like an issue with the current versions.
    I know it's not my PC hardware because I can run 2017 AAA games at 120+ FPS on max settings consistently.

    Has anyone else experienced this, and if yes, do you know a solution?
Working...
X