Announcement

Collapse
No announcement yet.

Controller lags when playing ZEN Pinball

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Controller lags when playing ZEN Pinball

    I've got a problem concerning ZEN Pinball, of which I haven't found any other thread:
    In single player, when I press the buttons for the flippers, they respond around half a second (or somewhat less) later (I feels like lag, but then local)
    I know you can alter the response time of when the flippers activate after pressing the button (ranging from 0,15 to 0,50) but that's not it. I've tried every setting from 0,15 to 0,50 but the flipper 'lag' is still there.
    I have compared my gameplay with the gamplay at a friends house and the difference is clearly noticeable. Other people who played ZEN Pinball on my PS3 and played it on that friend's PS3 as well experience the same difference in response time of the controller/flippers (where at my friends house the flippers clearly respond at the time you intend, instead of up to half a second later).

    My initial PS3 configuration was a 40GB version, but I upgraded my HDD to 320GB.
    Please note that ZEN Pinball is the only game I'm experiencing this type of 'lag' with and I currently own (including ZEN Pinball) 39 games.

    Are there more people experiencing this lag? I've had the same with the demo, so it could be my system.
    I'm really enjoying this game, cause it comes very near to the real thing (although that still feels better ) so I really hope someone can help me fix this
    Let me know! Thx

    Greeting, azazel1707
    Last edited by azazel1707; 11-01-2009, 09:01 PM.

  • #2
    I've found something interesting with my problem:
    I currently have 3 controllers, 2 Dualshock 3's and a Sixaxis. The Sixaxis is the only controller originally added in the box of my system.
    When I play with this controller, the lag is gone and I can play the game as intended!
    So for now my I'm helped

    I'm still curious though about why my 2 Dualshock 3 controllers DO experience the 'lag' and why it's (as far as I know) only with ZEN Pinball.

    Comment


    • #3
      Are you sure it's not your tv? When I play on my Sharp tv there is no lag. But last night I hooked up the PS3 to my Sony and it was lagging similar to what you posted. I think I read somewhere that some TVs have a "Game" setting option you need to select to stop games from having the lag response with the controller.

      Comment


      • #4
        You could try adjusting the button sensitivity in the options. By default, you have to push the buttons in a bit before they will register, to mimic how real pinball controls work. However, you can reduce the pressure threshold to 0 so that they activate instantly.

        If you've already tried this, then I would guess that the delay is a result of your receiver or TV's settings.

        Comment


        • #5
          this happens time to time, more often during 4 ball multi. Goes away after I reboot PS3. It seems the like PS3 is getting overloaded and has trouble keeping up with the inputs from the controller (kinda like if you had an older computer, the more windows and applications you had running, the more the delay in switching between applications or delay from inputs from the mouse). Very annoying because if you are trying to make a shot off the end of the flipper, the delay causes the ball to drain before the flipper activates. BOOOO !
          Check out my youtube videos for basic pinball strategies: caperUnderscore26

          Comment


          • #6
            I liked the demo and would have bought the game but i had the flipper lag and it was bad enough to be a dealbreaker,after reading a couple threads about this it seemed to me the only people that where having trouble where those with high end 120 mgh tv's,so i turned off my 120 mgh(going back to 60 mgh,a really easy menu process) and boom works great no lag at all on flippers.

            Comment


            • #7
              hi, sorry for the inconvenience, we are investigating the problem.

              Comment


              • #8
                I too suffer the lag problem, and yes, it's almost a deal breaker for me but I like the game so much I am considering putting up with it. I've not noticed lag problems with any other game. Then I discovered the forum so I'm hoping for a fix!

                In case there's a common pattern, here's what I'm running...

                I have one of the last of the fat PS3s, bought as bundle when they were being discounted as the slims hit the shelves in 2009.

                I upgraded its disk from 80 to 320GB

                I am using playTV

                I have the bluray remote controller and two dualshock3 controllers

                I have a panasonic plasma tv - 42G15 - on HDMI cable - so lag should be low, as I said no noticeable lag problems with any other games

                I sit about 4m from the PS3, controllers on wireless


                Can't think of anything else significant

                Paul
                -- edit -- I bought the game anyway, not long after the above post. Maybe the full game is better, but the lag is not a problem, as someone else said, it's somewhat representative of the electromechanical flipper system. I also turned off the arcade effects as I found them annoying, so maybe that helps.
                Last edited by speculatrix; 11-28-2010, 12:44 PM.

                Comment


                • #9
                  Haven't had this problem for quite some time...but I haven't been playing as much either.
                  Check out my youtube videos for basic pinball strategies: caperUnderscore26

                  Comment


                  • #10
                    Flippers still lagging

                    This lagging is terrible malfunction which wipes out all the fun. I have just bought PS3 for myself (I am over 40) since my son has one, and I wanted just to play Silent Hill but then I bought this ZenPinball not even checking it; as when I was young I used to be Pinball addict and master too. I have played hundreds of real different tables and I know flippers. Zen flippers, I think try, somehow to imitate weight of the ball when it is lying on it - then flipper has certain lag to push the ball - but this lag is present all the time. Half a second delay is impossible to play real Pinball where you are basing your reactions on certain connection between an eye and finger reaction - there is no way for me I can think to hit flipper earlier. Simpler programs as I remember them from the past did not have that problem. So I wish Zen can fix that somehow. And it is not controller - I drove that night I'd bought the game console to my son's to borrow old one - did not help at all. And I was so much excited. Pity so far.
                    Last edited by Malimarek; 04-24-2010, 12:40 PM.

                    Comment


                    • #11
                      Originally posted by Malimarek View Post
                      This lagging is terrible malfunction which wipes out all the fun. I have just bought PS3 for myself (I am over 40) since my son has one, and I wanted just to play Silent Hill but then I bought this ZenPinball not even checking it; as when I was young I used to be Pinball addict and master too. I have played hundreds of real different tables and I know flippers. Zen flippers, I think try, somehow to imitate weight of the ball when it is lying on it - then flipper has certain lag to push the ball - but this lag is present all the time. Half a second delay is impossible to play real Pinball where you are basing your reactions on certain connection between an eye and finger reaction - there is no way for me I can think to hit flipper earlier. Simpler programs as I remember them from the past did not have that problem. So I wish Zen can fix that somehow. And it is not controller - I drove that night I'd bought the game console to my son's to borrow old one - did not help at all. And I was so much excited. Pity so far.
                      Can you tell me more about your TV? Also, is this the PAL (European) or NTSC (North American) version of the game?

                      Also, have you tried changing the threshold so that the flippers activate more quickly? I believe that this option is in the Operators Menu, Extra Options (#4). It is at 15 by default, but you can lower it to 0 for immediate activation.

                      Comment


                      • #12
                        My TV is Philips LCD 42PFL9803H 42" DVB-T/C MPEG4* z Ambilight Spectra 2 i Perfect Pixel HD Engine. It is PAL game I guess since I am in Poland. I have been in the table setting and I have tried all settings, there is still no big luck – it gives impression it is not changing. Even though I had best one minute on Shaman table already. But since you mention TVset that got me thinking since this particular TV does heavy processing of the picture. So once I am back home I will play with its settings too. Regards. Marek

                        Comment


                        • #13
                          Originally posted by Malimarek View Post
                          My TV is Philips LCD 42PFL9803H 42" DVB-T/C MPEG4* z Ambilight Spectra 2 i Perfect Pixel HD Engine. It is PAL game I guess since I am in Poland. I have been in the table setting and I have tried all settings, there is still no big luck – it gives impression it is not changing. Even though I had best one minute on Shaman table already. But since you mention TVset that got me thinking since this particular TV does heavy processing of the picture. So once I am back home I will play with its settings too. Regards. Marek
                          What video output settings do you have enabled on your PS3, and are you using an HDMI cable to connect the PS3 to the TV? Can you tell what video mode your TV is in during the game?

                          Try changing the TV's "HD Natural Motion" setting and see if that helps.

                          Comment


                          • #14
                            Hi Malimarek,

                            I found the official solution from Philips that will answer and solve your question/problem.

                            I quote from their website, but it is in Dutch, so I will also translate it for you.


                            Philips LCD-TV 42PFL9803H 42 inch DVB-T/C MPEG4* LCD-TV met Ambilight Spectra 2 en Perfect Pixel HD Engine
                            42PFL9803H/10


                            Vraag:
                            Hoe kan ik vertraging op het beeld van mijn TV voorkomen wanneer ik een spel speel via een aangesloten gameconsole?

                            Antwoord:
                            Stel de TV in op de modus Game (Spel). Druk op Menu > TV menu (TV-menu) > Smart settings (Smart-instellingen) en selecteer de modus Game (Spel).

                            Translation into English:

                            Philips LCD-TV 42PFL9803H 42 inch DVB-T/C MPEG4* LCD-TV met Ambilight Spectra 2 en Perfect Pixel HD Engine
                            42PFL9803H/10


                            Question:
                            How can I prevent delays when playing games on a attached game console ?

                            Answer:
                            Selects the option 'game mode'. Press 'Menu --> TV Menu --> Smart Settings --> game mode'.

                            Please try this and give us feedback so others might have the answer to their problem too if they have the same TV.

                            Kind regards,
                            swprozee1

                            Comment


                            • #15
                              Thanks for the helpful information, swprozee1!

                              Comment

                              Working...
                              X