No announcement yet.

Cabinet button mapping - need help please

  • Time
  • Show
Clear All
new posts

  • Cabinet button mapping - need help please

    So I have x360ce installed and have mapped buttons in order to use FX3 in cabinet mode (for the most part).

    However I have issues that I cannot resolve.

    I am using zebsboards plunger kit for a controller.

    My main issue is that tables are telling me to press launch to start table well I am pressing the button I have for launch purposes with no luck - it doesn't work (button chosen is my launch ball button). This is button registers in the x360ce utility just fine.

    Additionally if I have x360ce installed and running when FX3 starts my keyboard controls only partly work. Meaning I can navigate around with the keyboard ok and exit out but once again ENTER (i.e. launch) does not work. Very weird issue.

    Any ideas?

    Also I read a lot of people have this all working just fine but its very hit or miss for me. Anyone care to post exactly how their buttons are mapped for 360ce?



  • #2
    Greg, I was having the same type of issues when I was trying to use x360ce. I could never get it to work correctly. I decided to purchase xpadder. Let me tell you it was the BEST decision. The software is super easy to use. It runs on startup and loads the profile (key mapping) I setup for FX3.

    Another cool feature... it gives you a graphical interface where you can drag and drop your buttons to mimic your cabinet buttons layout. Its very easy to setup and I have not had one issue with it. Well worth the $10.


    • #3
      Hi Greg,

      I also have a standard Zebsboards kit V2 and I'm having the same problem as you!

      I've lost weeks and days of sleep and nothing to get the analog plunger to work.

      I have updated all necessary programs for the correct operation of x360ce. I have net framework 3.5 enabled. I have updated version 4.7, and directx and C ++ 2013 and other versions are all installed.

      I updated the Zeb's plunger firmware for v2.4 keyboard.
      Run x360ce from "c:/program files (x86)/steam/steamapps/common/pinball fx3" directory
      I configured the executable in control 1, clicked auto and saved and started FX3 and I do not have the launch plunger in operation.
      The buttons work normally but plunger I can not make it work!
      I made other attempts at the settings and not to avail.

      I tried to make new tests by modifying the firmware for gamepad v2.3 again.
      In this firmware I was able to get results with nudge when I nudged my pincab.
      It happens that the buttons only worked through the FX3 menu. When I start the table do not work!

      I tried to modify the buttons in both firmwares in the option of controls in FX3, but without success.

      My problems are very similar to yours...

      In fact I can play without x360ce but without the nudge function and the analog plunger. But I really want to see this working properly.

      I see that many people who own the plunger of zebsboards are getting to use the analog plunger and nudge with FX3, but I honestly do not know what else to do.

      Did you get any news these days?

      I'm looking for new directions.

      Well, I need to make it work so I can configure Pinup popper.

      Any help is welcome!