Announcement

Collapse
No announcement yet.

Windows 10 - Required firewall settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 10 - Required firewall settings

    Hi,

    I've just installed Pinball FX3 and found out that I had to temporarily change my (Orange Livebox) router’s firewall configuration from “Custom” to “Medium” to get rid of the following error:

    Screenshot (148).jpg

    What incoming (hopefully: none) and/or outgoing ports do I have to open in the firewall for the game to operate normally? I need the “Custom” settings to allow some other apps to function…

  • #2
    Is there no way to allow the application in the router directly? Or is it getting dinged on your computers end via software there.

    Comment


    • #3
      That's exactly what I'm willing to do.

      The issue is not in Windows' firewall, since modifying the firewall settings (towards the "unsafer" end of the scale) in the router (i.e. the ISP-supplied box that connects my home network to the Internet via FTTH) suffices to get rid of that message. So the application in the Windows 10 PC is making network requests that are blocked by the router's firewall, which are unblocked when I switch to the "Medium" setting. What are those requests? Knowing what they are, I should be able to add the necessary rules to the router's "Custom" configuration...

      I could discover that using e.g. Wireshark, but I thought someone here might have the information available, would save me quite some time.

      Comment


      • #4
        Based on your other post am I to guess you are also running this though the Microsoft store and not Steam?

        Can you download the Steam version with the free table to see if that works?

        Comment


        • #5
          The Steam version doesn't have the firewall issue

          Yes, I'm running the Microsoft Store "distribution" of Pinball FX3.

          I've tried the Steam "distribution" and it doesn't report the connection problem depicted in my initial post.

          Comment


          • #6
            Originally posted by sba923 View Post
            What incoming (hopefully: none) and/or outgoing ports do I have to open in the firewall for the game to operate normally? I need the “Custom” settings to allow some other apps to function…
            I've just installed the Windows Store version to test this for you, details below.

            Microsoft Store (PinballFX3_W10.exe)
            Port: 443
            Port: 80

            There's often a dozen IP connections on those ports, far more than Steam which seems to rely upon 2-3.

            Steam (Pinball FX3.exe)
            Port: 6002
            Port: 80
            Last edited by MBeeching; 01-09-2019, 12:29 PM.

            Comment


            • #7
              Well... you can't be referring to outgoing ports! Outgoing HTTP (port 80) and HTTPS (port 443) -- for IPv4 -- are of course open in my router's firewall, otherwise I wouldn't be able to connect to any websites...

              I've checked with Wireshark what's going on.

              Opening outgoing TCP port 6002 solved the issue.

              Thanks for the lead ;-)
              Last edited by sba923; 01-09-2019, 08:52 PM. Reason: added answer to initial question

              Comment

              Working...
              X