Results 1 to 8 of 8

Thread: Choppy framerate, unplayable on Windows 10

  1. #1

    Angry Choppy framerate, unplayable on Windows 10

    Whenever I open Pinball FX2 for Windows 8 or Pinball FX2 for Windows 10 it lags my entire PC and I get about 5-10 frames per second in the game, making it unplayable.
    As soon as I exit my PC goes back to normal.

    It's weird because I used to be able to play these games without any issue, it only seems like an issue with the current versions.
    I know it's not my PC hardware because I can run 2017 AAA games at 120+ FPS on max settings consistently.

    Has anyone else experienced this, and if yes, do you know a solution?

  2. #2
    Community Manager McLovin's Avatar
    Join Date
    Apr 2017
    Posts
    447

    Default

    Hello there,

    could I ask for your PC specs? If you play around with the video options is there any difference?

    Is the menu slow as well, or just the tables themselves?

  3. #3

    Default

    Quote Originally Posted by McLovin View Post
    Hello there,

    could I ask for your PC specs? If you play around with the video options is there any difference?

    Is the menu slow as well, or just the tables themselves?
    The moment I open the game it begins to lag, so it's not just the tables.
    I have tried messing with all of the video settings and putting them on the lowest options.

    PC Specs:
    Windows 10 64-bit
    16GB RAM
    Intel i5 4670K CPU @ 3.40GHz
    R9 280X 3GB GPU

    Also tried on laptop with these lower specs:
    Windows 10 64-bit
    16GB RAM
    Intel i7 CPU @ 2.60GHz
    GeForce GT 650M 1GB
    Last edited by 2hard4me; 10-19-2017 at 05:09 PM.

  4. #4

    Default

    Still can't seem to solve the problem.
    Any suggestions?

  5. #5

    Default

    Still waiting for a response.
    Thanks

  6. #6

    Default

    Bump...anyone?

  7. #7
    Member
    Join Date
    Mar 2010
    Location
    The Netherlands
    Posts
    47

    Default possible solution

    Quote Originally Posted by 2hard4me View Post
    Bump...anyone?
    I would like to respond as nobody seems to help you out further.

    1 thing comes to mind reading about your problem.

    I know the Intel CPU you have has a Integrated GPU (4600) and it might be that Zen Pinball is running on the far slower Integrated GPU rather than your faster R9 280X 3GB GPU.

    Please do the following:
    Go into your BIOS of your computer and disable onboard graphics completely !!!
    That way we force any game to start running on your R9 280X 3GB GPU.

    Please let me know if that solved your problem. :-)

  8. #8
    Community Representative hajdu's Avatar
    Join Date
    Nov 2017
    Posts
    64

    Default

    Hey Guys,
    so sorry about this!
    But anyways swprozee1 is absolutely right and this would be my advice too.

    Thank you swprozee1 for helping out a fellow player!

    Wishing you all a happy holiday season!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •