Results 1 to 6 of 6

Thread: Critical bug - Paranormal (and possibly other tables)

  1. #1

    Default Critical bug - Paranormal (and possibly other tables)

    Hi Zen, I’ve encountered a game-breaking bug while playing on the Paranormal table. This seems to be the same issue I encountered on this and another table, on Zen Pinball 2 on Wii U. Occasionally, something will go wrong and there will be no balls available in play, or to shoot. The only way out is to end/restart the game.

    It’s happened to me a few times now on the Switch version. I’ll describe what has happened to the best of my memory: Each time, I was playing on the “Doppleganger” multiball mode. Something seems to go wrong with the table keeping track of the active balls. Sometimes a ball will drain, but a new one will be immediately relaunched (from the plunger) even though I am certain I didn’t have ball saver active. I’m not 100% sure if this has triggered the bug every time, but I’ve seen it happen at least twice in the moments before the table gets “stuck”.

    At some point, the ball will either be locked (for a jackpot) or drain, and that’s it - no more balls are released to the table or the plunger. Unfortunately I haven’t been recording my play when it has happened, but I’ve taken some footage after it’s occurred. http://youtu.be/fAcHu5_0JwM here is what it looks like after locking a ball, and http://youtu.be/z_O2H3ndb2w here is after the ball has drained.

    Also, sometimes after things seem to go wrong (a relaunch that shouldn’t have happened), a ball will re-enter the play area (after being locked in a sinkhole) and it will be waving around, seemingly in the pattern followed by the magnetic ball beneath the table’s surface. The ball will “stick” to the flippers (while still waving around) and can be “unstuck” by flicking the flipper, or nudging the table. The last time this issue happened to me, it stuck to the flipper and I managed to nudge it off and out of play, which resulted in the second video linked above. Earlier on, I captured a little bit of footage http://youtu.be/hsEs7NGgDaY here that shows the ball wobbling after it came back into play, but then it stopped and went back to normal (hence my quick pause).

    It seems like this bug could be caused by the ball that sits below the table’s surface (and applies the magnetic effect during multiball). Perhaps the table doesn’t recognise that there’s a problem because of the additional ball? Is there any way to fix it with a “table reset” option or something happening after a certain amount of time without any activity (I assume there is already a mechanic such as this in place, but there’s something wrong with regards to the additional ball under the surface)? Even a “sacrifice ball” option that resets the table would work.

    This issue may not affect 99% of players, because it seems to be rare, but the games that go for hours and hours only have an ever-increasing chance of encountering it, and it’s a killer. I have the game still saved just in case we can get this fixed - I was gunning for the number one spot after about 12 hours of play. Please let me know if this can be looked at, and/or there’s anything else I can do (send an email, etc). I love this game.
    Last edited by gaz5021; 01-13-2018 at 03:10 AM.

  2. #2
    Senior Member Tech101's Avatar
    Join Date
    Jan 2012
    Location
    Michigan
    Posts
    760

    Default

    I had that same thing happen to me. Think it was Adventure Land where I kept losing a ball in multiplayer yet I kept getting it back. Went on for a few minutes. I've also had it not drop the balls in the Sky Eye Multiball twice in a row. Seems to be when I play handheld I get more problems then when I'm docked.

    How do you mostly play?

  3. #3

    Default

    Quote Originally Posted by Tech101 View Post
    I had that same thing happen to me. Think it was Adventure Land where I kept losing a ball in multiplayer yet I kept getting it back. Went on for a few minutes. I've also had it not drop the balls in the Sky Eye Multiball twice in a row. Seems to be when I play handheld I get more problems then when I'm docked.

    How do you mostly play?
    I play 100% docked.

  4. #4
    Junior Member
    Join Date
    Mar 2012
    Posts
    22

    Default

    I've had a case happen one time where after locking a ball and selecting a mode, the ball released and the view returned to normal, but the cube kept spinning whenever I used a flipper. I was in a mode with a timer, and that remained paused as well. I'm unfortunately not sure whether the ball was actually being locked, or if I already had two locked and it was just being held in place by the pin.

  5. #5

    Default

    Quote Originally Posted by jothki View Post
    I've had a case happen one time where after locking a ball and selecting a mode, the ball released and the view returned to normal, but the cube kept spinning whenever I used a flipper. I was in a mode with a timer, and that remained paused as well. I'm unfortunately not sure whether the ball was actually being locked, or if I already had two locked and it was just being held in place by the pin.
    Man that's pretty weird. Did your game continue though, or did you eventually have no balls left to play?

    My main concern is when that happens and I have no choice but to end the game. It really sucks. My game is still saved on about 6 billion with the super jackpots up around 60 mil. On ball 1 with a couple of extras up my sleeve.

  6. #6
    Community Representative hajdu's Avatar
    Join Date
    Nov 2017
    Posts
    137

    Default

    Hey Guys,
    can I ask how many switch users are experiencing this issue?
    Thank you in advance!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •