Results 1 to 5 of 5

Thread: Game randomly exiting fullscreen when launching with cabinet mode options

  1. #1

    Default Game randomly exiting fullscreen when launching with cabinet mode options

    Hey

    I had initally posted this on steam forums but got no responses...

    I've got a verry irritating problem where the game will exit fullscreen mode randomly. I've seen it happen once or twice on my main pc when just launching the game directly from steam.

    I also have it happen on my pinball cabinet so i had disabled any launchers, any launch before & after script and any kind of extra tools in pinballx (so using default settings for it). It still happend.

    Then to exclude pinballX itselve i started running the game from commandline like so (if you got cabinet mode) and sure enough the game still exited fullscreen on the last launch of sorcerers lair so it's not pinballx as it happens without pinballx as well. So either something windows / drivers related or even the game itselve

    C:\Program Files (x86)\Steam>steam -applaunch 442120 -table_Mars
    C:\Program Files (x86)\Steam>steam -applaunch 442120 -table_Citadel
    C:\Program Files (x86)\Steam>steam -applaunch 442120 -table_Archer
    C:\Program Files (x86)\Steam>steam -applaunch 442120 -table_Citadel

    I also tried updating video drivers, i reattached my two screens so they are all attached to my nvidia card and disabled onboard video (from cpu) in bios. I have tried with full screen optimasations option disabled on the exe, have tried with running the game as administrator (elevated). I have game mode / game dvr disabled through policies and am currently running windows 10 professional 1803 on my cabinet (not 1809 yet)

    The weird part is, that when the loading screen appears the game is running fullscreen without a problem but when it happens it always happens just before the table itselve is fully loaded / about to be displayed or when that messages comes up asking if you want to start a new game or continue.

    This problem is starting to anoy me and i can't find a definitive solution for it.

    I'm not running anything fancy in the background that might steal focus from pinball fx3 that could cause this.

    I do have teamviewer installed but it happens also when nobody is connected to the cab / pc and i'm not sure if teamviewer can be the cause when nobody is connected (have not tried uninstalling it)

    Does anyone else have this problem ? I always have to have a keyboard & mouse attached to my cabinet just in case it happens i can alt+tab back.

    I know of one other person on a facebook group having a similar problem but not sure it's the same cause and i have yet to find the cause
    Last edited by joyrider3774; 12-28-2018 at 02:25 PM.

  2. #2
    Junior Member
    Join Date
    Dec 2017
    Posts
    17

    Default

    I have a very similar setup as yours. NVIDIA card (1030) and only run in cabinet mode with PinballX. I frequently got screen meltdowns and entire system lockups. Mine occurred during game play and not at launch screen as yours does. Some games crashed less than others. I never got crashes with an older video card I had and it was too slow to play (ran good under FX2) so led me to believe I had a video card problem. I also had the latest drivers and tried to adjust the graphics settings all to no avail. Running 32-bit Win 10, not sure the version, should be the latest or close to it.

    Finally I got fed up and sent my video card for repair as it was under warranty. Got the card back and installed and it was better, though still having crashes not as frequent but still too many. I almost ordered a new card then but I happen to have two (2) Dell Optiplex PCs, one for general use and the other for the cabinet. I decided to swap the video cards and hard drives between the two and now the crashes are almost non-existent, still occur on occasion and now they don't lock my machine up, I can escape back to PinballX. My main screen goes black or resets with the game still playing (I can hear it playing), backbox remains running. Both use the same card. Escaping back to PinballX the monitor returns to normal display.

    I would conclude you have a hardware issue like I did. Swap in an old video card if you have one and see if your crashes clear up. The games will still run, just slowly, and will allow you to test to see if the problem goes away on the old card. FX3 is very graphic intensive and one little hardware glitch (bad memory?) on card will cause the crashes. I have a GIGABYTE card and the repair did not specify what was fixed, only that it was repaired.

    I think I had two (2) problems, one on the card and another on the motherboard. I still get the occasional crash, and now its at an acceptable level. And who knows, perhaps FX3 has a few bugs in there too.

  3. #3

    Default

    my game does not crash, nor does my windows or any other app it just exits full screen from time to time. Which can happen with some program stealing focus, driver or game issue. The card is brand new i bought it like 2 weeks ago and is working perfect. Exiting from game to pinballx works without a problem also. It's just the exiting fullscreen thing and having to alt+tab or alt+enter back into it. I don't think the card is faulty it was a sealed box not 2nd hand buy. If i'm to bet its something windows 10 related or drivers but i'm running the latest ones.

    On a side note i only have this problem with pinball fx3, not with visual pinball not with malzbies pinball collection nor with pinball wicked or bigscore pinball although i do run some of thos windowed full screen. Actually i think i might switch the game settings to run windowed full screen to go around the problem. If it still minimizes then it's probably pinballx or some other program stealing focus away from pinball fx3

  4. #4

    Default

    Instead of fighting to stay fullscreen i choose to be running borderless windowed now and that works great now don't have a problem anymore. The only downside is i run at a lower resolution now because my windows playfield screen is set at lower resolution but i'm fine with that still looks good and everything playable so i tested around 10-15 table launches including my launcher (where i did had to change the forceforegroundwindow option to bring my launcher once to the foreground at startup otherwise it would sometimes not receive input). So i'm fine with this it's no solution for the problem but it works for my cabinet

  5. #5

    Default

    I was having the same issue and resolved it by changing a few things in Windows + Steam. Not sure it will work for you, but something to check.

    1 - Turn off Windows updates, that little pop-up box can kick you out of fullscreen, especially if you are running in HDR mode.
    2 - Turn off the Steam overlay, little things can make pop-ups happen and cause a window to go out of full screen.
    3 - Turn off Steam notifications.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •