Results 1 to 12 of 12

Thread: Stuttering/Jerky Gameplay on AT&T Moto Atrix 4G

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Posts
    4

    Default Stuttering/Jerky Gameplay on AT&T Moto Atrix 4G

    It was like Christmas morning today, finally being able to install Zen Pinball on my phone!

    But when I started playing Sorcerer's Lair, I immediately noticed that the ball would freeze for a split second every few seconds, making for very unpleasant gameplay. This jerky stuttering only got worse during multiball.

    I tried a bunch of different settings, rebooted my phone, etc. and nothing made this problem any better. I have the other Tegra pinball game on Android, and it plays smoothly as usual (for all the good it does me - it's not a great game).

    Anyway, I can tell Zen Pinball on Android would be an amazing game if not for this issue. I really hope you can fix it - I would buy more tables without hesitation if it was running right.

  2. #2
    KickBeaten Down
    Join Date
    Mar 2010
    Posts
    919

    Default

    We're investigating!

  3. #3

    Default

    No freeze here (on acer tablet with tegra 2) but obviously some 'framerate' issues it seems, particularly on Fantastic Four where it's almost game breaking .... the table plays but it's hard to hit the shots you need, even the mission hole wich is super easy to hit normally.

  4. #4
    Senior Member shogun00's Avatar
    Join Date
    Feb 2011
    Location
    Western NY (USA)
    Posts
    2,797

    Default

    Try turning off the "Arcade Effects".

    This is something I had to deal with on PinMame. It's all about the processing power and all of those special effects take up quite a bit of it. Unfortunately, my CPU couldn't handle most of those effects, so I had to turn some of them off to make the tables play smoothly.

    I assume that the cell phones are the same way. Some are going to work better with the game than others.

  5. #5
    Junior Member
    Join Date
    Nov 2011
    Posts
    4

    Default

    I did try turning off arcade effects, and it did not improve the "lagging". In fact, I tried turning off everything that I could in the options - and there was absolutely no change.

    Plus, my phone can run graphics-intensive Tegra games like Shadowgun and Riptide GP perfectly - so I have to think this is more of a bug than an inadequacy of the device itself.
    Last edited by SneakyTT; 11-30-2011 at 07:13 PM.

  6. #6

    Default

    Try turning off the Dot Matrix Display. I know that isn't ideal, but it does make the iPad 1 version run a LOT smoother, so I'm guessing the same is true on the Android version. Hopefully Zen can optimize the DMD or lower the res on it or something because it definitely seems to be bogging down the framerate and playing without it isn't very nice.

  7. #7
    Junior Member
    Join Date
    Nov 2011
    Posts
    4

    Default

    The latest update has improved the ball motion somewhat - it's noticeably better. But the ball motion is still "jerky", and during multiball the framerate drops a lot.

    I hope you can get the ball motion to be smooth... I've been playing anyway, and it really is an amazing pinball game, but would be so much better with perfect motion.

  8. #8

    Default

    I got this for my Droid X2 (Android 2.3.4). It has pretty serious framerate issues. It's not unplayable, at least by cell phone standards, but it's awfully close. (I'm shutting down as much non-essential stuff as possible in my apps list and turning off both the scoreboard and the arcade effects, by the way.)

    I know the tables were designed for far more powerful consoles, but is there no way to offer some phone-centric graphics settings for the tables? I mean it's absolutely gorgeous, but I feel like we've got the textures and detail set on "ultra" for a four inch screen. If it's any kind of option for future updates, I'd rather have 30fps than the ability to count rivets in the table's rail network.

  9. #9
    Junior Member
    Join Date
    Nov 2011
    Posts
    4

    Default

    Yeah I've been playing Sorcerer's Lair, even with the framerate and stuttering issues. I agree, it's playable, but just barely.

    I have played hundreds of games of all sorts on my phone, and none of them have this kind of problem. I really hope they can fix it, because it really is a phenomenal game.

    I'll be interested to see how Pinball Arcade runs on this phone when it comes out in a few months.

  10. #10
    KickBeaten Down
    Join Date
    Mar 2010
    Posts
    919

    Default

    It will be a little while before we get all the necessary devices (such as the Atrix) into the Budapest office. I am very hopeful that we will be able to resolve the problem, since we had it running smoothly on an Atrix at Google I/O (May 2011). But as I said, it will probably take a while to get the devices, get through the holidays, etc.

  11. #11
    Junior Member
    Join Date
    Feb 2012
    Posts
    6

    Default Acer a100

    runs smooth on my Acer A100 the only time i get slow downs is when background apps start up. if you turn off automatic updates on them or close them down then it will run much better.

  12. #12
    Junior Member
    Join Date
    Apr 2012
    Posts
    2

    Default

    exact same issue on the Motorola Photon 4G

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •