Hi everyone. First post from me, but I wanted to report a bug in the FunHouse emulation. I'm seeing this on the Switch, and I don't know if it's happening anywhere else.

No matter which "mode" I choose, if I'm playing FunHouse and I score a jackpot (trap door during multiball) or get a high score, the "jackpot music" and its corresponding light show go absolutely nuts. I don't have the ability to upload a video of this, so I'll try to describe it as best I can.

On a real FunHouse table, the song starts off with a set of booms that hit every couple of beats or so. The lights and flashers light in tandem with the booms as well, and then when the booms are done, the playfield lights settle into a rhythm that goes along with the music. (In particular, the inner and outer clock lights alternate with the beat.)

In Pinball FX 3, the booms sound like machine-gun fire, and the lights flicker wildly as though the table is trying to run the light show at 100x normal speed. This sometimes causes parts of the game to become slow to respond - for example, while the booms are going off, if I hit Rudy's mouth, he doesn't react to the hit until the booms stop. Various other scores and sound effects also get delayed here. When I get to the initials screen, the display is slow to update while this is going on, making the match animation very choppy.

It seems this is the only part of the game that glitches out like this. The table recovers as soon as multiball ends, and I haven't seen any other issues with lights, sounds or music. Just this one part. I'm guessing that it has to do with the powerup system and the hooks into the emulator that you need to do things like increased scoring.

Thanks in advance for looking into it. FunHouse is one of my all-time favorite tables, and I'd love to see it working flawlessly. And thanks for such excellent simulations in general.