Results 1 to 11 of 11

Thread: No sound and choppy frame rate

  1. #1
    Senior Member shogun00's Avatar
    Join Date
    Feb 2011
    Location
    Western NY (USA)
    Posts
    2,823

    Default No sound and choppy frame rate

    I'm new to Steam and I just bought Pinball FX 2 (first game) along with the PFX2 Core Pack. For some reason, I'm not getting any sound and the frame rate is pretty choppy with the flippers not responding so well.

    All of the hardware is above the recommended amount. I think it's just a couple of settings I need to adjust on Steam, but I'm not sure what.

    Can someone please help me, since I don't play PC games much.

    My Hardware:
    OS Version - Windows 7
    Processor - AMD Dual Core @ 2.6GHz
    Memory - 3.7 GB
    Graphics card - Radeon 4200 HD
    Sound card - Realtek ALC662

  2. #2

    Default

    I'm guessing that the Radeon 4200 is an integrated video card built into your mainboard. If so, the speed of the system ram will have an impact on your performance (ie, ddr2 or ddr3 ram). Built in cards use system ram as video ram.
    PSN ID - cmotors
    Steam ID - Incriminified

  3. #3
    Senior Member shogun00's Avatar
    Join Date
    Feb 2011
    Location
    Western NY (USA)
    Posts
    2,823

    Default

    Quote Originally Posted by Incriminified View Post
    I'm guessing that the Radeon 4200 is an integrated video card built into your mainboard. If so, the speed of the system ram will have an impact on your performance (ie, ddr2 or ddr3 ram). Built in cards use system ram as video ram.
    Yes, it's integrated on the board. It's DDR2 Ram. The board technically has 4GB, but .3GB is reserved for the graphics chip and it can use more of the actual Ram if it needs to. Surprisingly, it runs smoothly when the ball rolls. It's the flippers that are not responding fast enough and when they do that's when I see the hick-ups. Considering the minimum requirements are far less than the recommended, I shouldn't be experiencing this problem at all.
    Last edited by shogun00; 05-10-2013 at 08:39 PM.

  4. #4

    Default

    Ok, then you should be doing good one would think. I haven't tried it out yet until I get home, are you able to reduce the display resolution of the game to see if that has an effect?
    PSN ID - cmotors
    Steam ID - Incriminified

  5. #5
    Senior Member shogun00's Avatar
    Join Date
    Feb 2011
    Location
    Western NY (USA)
    Posts
    2,823

    Default

    Quote Originally Posted by Incriminified View Post
    Ok, then you should be doing good one would think. I haven't tried it out yet until I get home, are you able to reduce the display resolution of the game to see if that has an effect?
    No! I haven't tried that and there is an option to adjust the res in game. Thanks for the suggestion.

    Any idea on the sound?

  6. #6

    Default

    You may want to try and download the latest drivers for your sound card. Usually this is through your mainboard manufacturer. However, sometimes there are newer drivers straight from the soundcard manufacturer (in this case Realtek) that don't get updated on the mainboard manufacturer's website.

    This same idea holds for your videocard as well, make sure you are using latest drivers. Just as above, from the mainboard manufacturer, or possibly even later drivers from AMD
    PSN ID - cmotors
    Steam ID - Incriminified

  7. #7
    Senior Member shogun00's Avatar
    Join Date
    Feb 2011
    Location
    Western NY (USA)
    Posts
    2,823

    Default

    Thanks for the advice.

    I fixed the sound problem, it was actually a setting in Windows 7. It was defaulted to the HDMI port, instead of the speakers. Windows 7 uses all of the available of the options, while Steam only uses the default. I set the speakers to the default and I got sound.

    The hiccups are still present in the video. Changing the resolution does help. I'll need to monkey around with the video settings. I'll try updating the drivers and check the other settings (such as monitor and display).

  8. #8
    Senior Member
    Join Date
    Jan 2012
    Posts
    823

    Default

    Here is the link to find your latest graphics driver. I didn't know if your running a 32 or 64-bit system so I didn't include the direct link.

    http://support.amd.com/us/gpudownload/Pages/index.aspx

  9. #9
    Senior Member shogun00's Avatar
    Join Date
    Feb 2011
    Location
    Western NY (USA)
    Posts
    2,823

    Default

    Quote Originally Posted by surf1der View Post
    Here is the link to find your latest graphics driver. I didn't know if your running a 32 or 64-bit system so I didn't include the direct link.

    http://support.amd.com/us/gpudownload/Pages/index.aspx
    It's a 64-bit system, but don't worry about it. I'll figure it out.

    I thought the problem was with Steam (and PC gaming), which I'm not familiar with. I'm all to familiar with Windows and all of it's annoying little settings.

    I really wish the game was available on Ubuntu Linux.

  10. #10
    Senior Member
    Join Date
    Jan 2012
    Posts
    823

    Default

    It doesn't sound like a steam problem. Try fiddling with all your graphics settings. Anti-aliasing for example can hog resources. Try reducing or turning it off if the game has it.

  11. #11
    Senior Member shogun00's Avatar
    Join Date
    Feb 2011
    Location
    Western NY (USA)
    Posts
    2,823

    Default

    Quote Originally Posted by surf1der View Post
    It doesn't sound like a steam problem. Try fiddling with all your graphics settings. Anti-aliasing for example can hog resources. Try reducing or turning it off if the game has it.
    I already tried that. It's either a driver with the graphics card or the monitor. Or it's a setting on Windows 7 that I need to change. It's just a process of elimination.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •